Wire SVN broken?

I tried to connect to it but it didnt seem to work, could someone give me a working link?

edit: I think I figured out the preblem, I need a pw anonsvn or something but tortoise isnt prompting me, I just tried phx3

edit: and some help would be appreciated

They moved their SVN to a different server. You can find more information here.

SVN Tutorial: http://www.facepunch.com/showthread.php?t=688324
The new wire link is on there as well.

i dont know y people dont just give a friggin DIRECT answer. I SAY NO MORE LINKS! Just ANSWER the poor people!

The point of the tutorial is to not have to explain everything over and over again each time someone asks.
Blame those who give you sucky links.

I am using the right wire svn, tortoise just likes to fuck with me, I cant enter a pw anywhere, please tell me when I should be prompted
I get this error for phx3: Checkout from https://phoenix-storms.svn.sourceforge.net/svnroot/phoenix-storms, revision HEAD, Fully recursive, Externals included
OPTIONS of ‘https://phoenix-storms.svn.sourceforge.net/svnroot/phoenix-storms’:
could not connect to server (https://phoenix-storms.svn.sourceforge.net)

Has SVN worked before? If not, this might be a firewall issue.
Make sure that Tortoise SVN isn’t being blocked by the firewall you’re using.