Wiremod errors

Could someone help me with this error?


entities/gmod_wire_hoverball/init.lua:249: bad argument #1 to 'SetAngles' (Angle expected, got number)

What’s the error do? When does it appear?

The error occurs when I try to spawn a hoverball. I replaced the wire_hoverball.lua file thinking that might fix it but it was not successful. I just downloaded wire svn and now I have errors. I think there are more stools with this error but I only tried wire hydraulic and hoverball. Hydraulic worked btw.

EDIT:

This is all the errors with wiremod;



entities/gmod_wire_forcer/init.lua:26: bad argument #1 to 'max' (number expected, got boolean)

entities/gmod_wire_grabber/init.lua:258: bad argument #1 to 'SetAngles' (Angle expected, got number)

entities/gmod_wire_igniter/init.lua:78: bad argument #1 to 'SetAngles' (Angle expected, got boolean)

entities/gmod_wire_hoverball/init.lua:249: bad argument #1 to 'SetAngles' (Angle expected, got number)

weapons\gmod_tool\stools/wire_servo.lua:98: attempt to call method 'SetMotor' (a nil value)
`
entities/gmod_wire_thruster/init.lua:231: bad argument #1 to 'SetModel' (string expected, got Vector)

entities/gmod_wire_trail/init.lua:105: bad argument #1 to 'SetAngles' (Angle expected, got string)

[ents.Create( "prop_physics" )] This frame you have created 171528288 entities! (Lua Error!?)

All of the errors deal with wire stools except for the last one. The last error crashed gmod. That error is from wire models. I tried to spawn a button model from the spawnlist and it was invisible. Plus the error overloaded the console. I barely had enough time to copy the damn error. This is bugging the hell out of me.

Try reinstalling it again, and make sure to completely delete every trace of wiremod before installing it again, otherwise some problems may be translated into your new install of wiremod.

Edit: whoops i accidentally rated ur first post to nice/polite/friendly lol

sorry to change the subject, but you can just re-rate the rating.

[editline]10:49PM[/editline]

and i wasnt having problems with anything but e2, so i reinstalled and now i have errors all over

FIXED: I got to looking through the svn files and my old backup files. As it turns out, tortoise svn did not download everything. I got the missing files from my backup files and now wire is working but it’s the old wire.

p.s. Thanks for the rating I guess.

i dont have any backups, so does anyone have a different solution?

I’m having the exact same problem as Rockerdoofus had. I get the “bad argument #1 ‘to set angles’” thing and it won’t spawn

the uses of wire hoverball are clear enough (objects that float without the need for cluttered numpad wiring). If anyone has an idea for how to fix it that would be freakishly awesome.

Download the latest SVN version. SVN Tutorial: http://www.facepunch.com/showthread.php?t=688324

I did, The SVN update I downloaded that was causing problems was updated yesterday and now the hoverball problem is resolved. I’m all good now.

Though I still have one off topic issue; theres a ship part in spacemod that looks like a gate room, but when a gate activates inside, the eventhorizon deletes the ship around it even though they arn’t even close to touching ><

I’ll be working on that little inconvenience for the next bit. But at least ships can fly with ma hoverballz now. ^^

Weld the stargate to the prop. Gates don’t destroy anything they’re constrained to.

Really? thanks a ton, I’ll give that a try

Asgard Teleporters don’t teleport anything they’re constrained to, and Rings don’t either. :slight_smile: