"with prop_static, it must be compiled with $staticprop!" -what does that mean!?

I’m making a map, and theres a big base in the centre, made of junk (megaton style) but some of the props won’t load, and i don’t know why…

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\avwos\sourcesdk\bin\orangebox\bin\vbsp.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\avwos\half-life 2 episode two\ep2” “C:\Program Files (x86)\Steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map”

Valve Software - vbsp.exe (May 19 2009)
4 threads
materialPath: c:\program files (x86)\steam\steamapps\avwos\half-life 2 episode two\ep2\materials
Loading C:\Program Files (x86)\Steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map.vmf
fixing up env_cubemap materials on brush sides…
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (0)
**** leaked ****
Entity prop_static (535.00 470.00 408.00) leaked! ( << WTF is that)

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (-512.0 0.0 352.5)
Leaf 0 contents: CONTENTS_SOLID
Leaf 1 contents:
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (0.0 330.3 92.2)
Leaf 0 contents:
Leaf 1 contents: CONTENTS_SOLID
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (0.0 156.6 86.1)
Leaf 0 contents:
Leaf 1 contents: CONTENTS_SOLID
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (0.0 685.8 104.7)
Leaf 0 contents:
Leaf 1 contents: CONTENTS_SOLID
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (0.0 512.0 24.0)
Leaf 0 contents:
Leaf 1 contents: CONTENTS_SOLID
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (0.0 330.3 286.7)
Leaf 0 contents:
Leaf 1 contents: CONTENTS_SOLID
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (0.0 156.6 286.7)
Leaf 0 contents:
Leaf 1 contents: CONTENTS_SOLID
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (0.0 685.8 286.7)
Leaf 0 contents:
Leaf 1 contents: CONTENTS_SOLID
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

*** Suppressing further FindPortalSide errors… ***
Processing areas…done (0)
Building Faces…done (0)
FixTjuncs…
PruneNodes…
WriteBSP…
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_01*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_01*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors…
Finding lightmap sample positions…
Displacement Alpha : 0…1…2…3…4…5…6…7…8…9…10
Building Physics collision data…
done (0) (26458 bytes)
Error! prop_static using model “models/props_c17/furniturebathtub001a.mdl”, which must be used on a dynamic entity (i.e. prop_physics). Deleted.
Error loading studio model “models/props_c17/furniturebathtub001a.mdl”!
Error! To use model “models/gibs/helicopter_brokenpiece_06_body.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/gibs/helicopter_brokenpiece_06_body.mdl”!
Error! To use model “models/gibs/helicopter_brokenpiece_04_cockpit.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/gibs/helicopter_brokenpiece_04_cockpit.mdl”!
Error! To use model “models/gibs/helicopter_brokenpiece_05_tailfan.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/gibs/helicopter_brokenpiece_05_tailfan.mdl”!
Error! prop_static using model “models/props_junk/sawblade001a.mdl”, which must be used on a dynamic entity (i.e. prop_physics). Deleted.
Error loading studio model “models/props_junk/sawblade001a.mdl”!
Error! prop_static using model “models/props_mining/bucket_mining01.mdl”, which must be used on a dynamic entity (i.e. prop_physics). Deleted.
Error loading studio model “models/props_mining/bucket_mining01.mdl”!
Error! To use model “models/props_mining/diesel_generator.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/props_mining/diesel_generator.mdl”!
Error! To use model “models/vehicles/prisoner_pod.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/vehicles/prisoner_pod.mdl”!
Error loading studio model “”!
Placing detail props : 0…1…2…3…4…5…6…7…8…9…10
Compacting texture/material tables…
Reduced 102 texinfos to 76
Reduced 16 texdatas to 14 (440 bytes to 318)
Writing C:\Program Files (x86)\Steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map.bsp
6 seconds elapsed

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\avwos\sourcesdk\bin\orangebox\bin\vvis.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\avwos\half-life 2 episode two\ep2” “C:\Program Files (x86)\Steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map”

Valve Software - vvis.exe (May 19 2009)
4 threads
reading c:\program files (x86)\steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map.bsp
reading c:\program files (x86)\steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map.prt
LoadPortals: couldn’t read c:\program files (x86)\steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map.prt

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\avwos\sourcesdk\bin\orangebox\bin\vrad.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\avwos\half-life 2 episode two\ep2” “C:\Program Files (x86)\Steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map”

Valve Software - vrad.exe SSE (May 19 2009)

  Valve Radiosity Simulator     

4 threads
[Reading texlights from ‘lights.rad’]
[48 texlights parsed from ‘lights.rad’]

Loading c:\program files (x86)\steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map.bsp
No vis information, direct lighting only.
Setting up ray-trace acceleration structure… Done (2.31 seconds)
600 faces
7418 square feet [1068226.00 square inches]
40 Displacements
65706 Square Feet [9461697.00 Square Inches]
0 direct lights
BuildFacelights: 0…1…2…3…4…5…6…7…8…9…10 (0)
Build Patch/Sample Hash Table(s)…Done<0.0065 sec>
FinalLightFace: 0…1…2…3…4…5…6…7…8…9…10 (2)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ThreadComputeLeafAmbient: 0…1…2…3…4…5…6…7…8…9…10 (2)
Writing leaf ambient…done
Ready to Finish

Object names Objects/Maxobjs Memory / Maxmem Fullness


models 5/1024 240/49152 ( 0.5%)
brushes 66/8192 792/98304 ( 0.8%)
brushsides 1176/65536 9408/524288 ( 1.8%)
planes 2088/65536 41760/1310720 ( 3.2%)
vertexes 729/65536 8748/786432 ( 1.1%)
nodes 491/65536 15712/2097152 ( 0.7%)
texinfos 76/12288 5472/884736 ( 0.6%)
texdata 14/2048 448/65536 ( 0.7%)
dispinfos 40/0 7040/0 ( 0.0%)
disp_verts 3016/0 60320/0 ( 0.0%)
disp_tris 4736/0 9472/0 ( 0.0%)
disp_lmsamples 166376/0 166376/0 ( 0.0%)
faces 600/65536 33600/3670016 ( 0.9%)
hdr faces 0/65536 0/3670016 ( 0.0%)
origfaces 339/65536 18984/3670016 ( 0.5%)
leaves 497/65536 15904/2097152 ( 0.8%)
leaffaces 588/65536 1176/131072 ( 0.9%)
leafbrushes 188/65536 376/131072 ( 0.3%)
areas 2/256 16/2048 ( 0.8%)
surfedges 3994/512000 15976/2048000 ( 0.8%)
edges 2149/256000 8596/1024000 ( 0.8%)
LDR worldlights 0/8192 0/720896 ( 0.0%)
HDR worldlights 0/8192 0/720896 ( 0.0%)
leafwaterdata 0/32768 0/393216 ( 0.0%)
waterstrips 31/32768 310/327680 ( 0.1%)
waterverts 0/65536 0/786432 ( 0.0%)
waterindices 474/65536 948/131072 ( 0.7%)
cubemapsamples 0/1024 0/16384 ( 0.0%)
overlays 0/512 0/180224 ( 0.0%)
LDR lightdata [variable] 277928/0 ( 0.0%)
HDR lightdata [variable] 0/0 ( 0.0%)
visdata [variable] 0/16777216 ( 0.0%)
entdata [variable] 3944/393216 ( 1.0%)
LDR ambient table 497/65536 1988/262144 ( 0.8%)
HDR ambient table 497/65536 1988/262144 ( 0.8%)
LDR leaf ambient 341/65536 9548/1835008 ( 0.5%)
HDR leaf ambient 497/65536 13916/1835008 ( 0.8%)
occluders 0/0 0/0 ( 0.0%)
occluder polygons 0/0 0/0 ( 0.0%)
occluder vert ind 0/0 0/0 ( 0.0%)
detail props [variable] 1/12 ( 8.3%)
static props [variable] 1/4028 ( 0.0%)
pakfile [variable] 212108/0 ( 0.0%)
physics [variable] 26458/4194304 ( 0.6%)
physics terrain [variable] 15940/1048576 ( 1.5%)

Level flags = 0

Total triangle count: 1438
Writing c:\program files (x86)\steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map.bsp
6 seconds elapsed

** Executing…
** Command: Copy File
** Parameters: “C:\Program Files (x86)\Steam\steamapps\common\left 4 dead\sdk_content\mapsrc\post-post-apocalyptic map.bsp” “c:\program files (x86)\steam\steamapps\avwos\half-life 2 episode two\ep2\maps\post-post-apocalyptic map.bsp”

The bit that’s confusing me is

Error! prop_static using model “models/props_c17/furniturebathtub001a.mdl”, which must be used on a dynamic entity (i.e. prop_physics). Deleted.
Error loading studio model “models/props_c17/furniturebathtub001a.mdl”!
Error! To use model “models/gibs/helicopter_brokenpiece_06_body.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/gibs/helicopter_brokenpiece_06_body.mdl”!
Error! To use model “models/gibs/helicopter_brokenpiece_04_cockpit.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/gibs/helicopter_brokenpiece_04_cockpit.mdl”!
Error! To use model “models/gibs/helicopter_brokenpiece_05_tailfan.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/gibs/helicopter_brokenpiece_05_tailfan.mdl”!
Error! prop_static using model “models/props_junk/sawblade001a.mdl”, which must be used on a dynamic entity (i.e. prop_physics). Deleted.
Error loading studio model “models/props_junk/sawblade001a.mdl”!
Error! prop_static using model “models/props_mining/bucket_mining01.mdl”, which must be used on a dynamic entity (i.e. prop_physics). Deleted.
Error loading studio model “models/props_mining/bucket_mining01.mdl”!
Error! To use model “models/props_mining/diesel_generator.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/props_mining/diesel_generator.mdl”!
Error! To use model “models/vehicles/prisoner_pod.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/vehicles/prisoner_pod.mdl”!
Error loading studio model “”!

What is “$staticprop!” and how do i fix this?

Please help.

Edit: I do understand that some props can only have certain properties, but the bathtub says it can be static, and it still won’t load.

Error! prop_static using model “models/props_c17/furniturebathtub001a.mdl”, which must be used on a dynamic entity (i.e. prop_physics). Deleted.

There you have it. You’re using props which are supposed to have physics. Same thing happens if you take a prop that’s made to be static, and make it as a physics.

You also have a leak, make sure that you map is sealed from the “void” with non func_ brushes.

If it don’t work make it a prop_physics with the “motion disabled” flag checked.

But it says in the model viewer that it can be static too…

Is there a way around this problem?

Do as I said.

If it says that it can only be a static object, make it static. If it says it can be something else and static, choose the something else

Valve gets it wrong a surprisingly large amount of the time. Which is annoying as fuck.

for static props that are supposed to be physics.

Make it prop_physics and have it Motion Disabled.

aha! larry_G your a genius. forgot about that.

CoLD_IcE said it first

@ Topic: Check compile log problems here: http://www.interlopers.net/errors/

[editline]12:06PM[/editline]

**** leaked ****

Description:
You have a leak. A leak is a hole in your map that exposes any entity in your map to the void (the black space outside your map).

Solution:
Fix the leak.

See also:
WIKI: leaks

This error will cause your map to fail compiling correctly

I know about the leak, when i posted this, it didn’t even have a sky box :S

It’s fixed now though, everythings working fine.

Thankyou EVERYONE that has posted and helped.