Wooden facemap. Again...

Hello. I just have wooden facemap syndrome on my model, but I can’t find any way to fix it. Any help? I remember somebody told me how to fix that, but I forgot D:

Thanks in advance

untap clamp S and Clamp T from the .vtf of the face texture. Or unless they’re not tapped, in which case tap them.

Doesn’t work ;(

I’m using breen facemap, btw.

Obviously I untapped everything and now I’m stuck…

Does it happen in HLMV or in game? If in HLMV try a different engine configuration

It happens in game and in HLMV. I donnu why it keeps happening. I decompiled Breen model, changed texture path and that’s all I did with model.

@Wraithcat, didn’t you tell about fixing that issue in some “combine assasin headhack” thread?

Jesus christ, this is at least the thousandth time I’ve seen this issue. Open the model in your 3D app, open the UV map editor, drag the map of the face up one full length. It’s a problem with the decompiler moving UV maps. It’s generally not a problem, since the texture technically tiles indefinitely, but faces are unique in that regard.

I loaded maps into 3ds max and it worked - in 3ds max. Facemap is still broken in SOURCE.

If that’s the case, then you’re doing something wrong with the VTFs.
Check them again to make sure you unclamped (and saved) S, T, and U. If that’s still not doing jack for you, go get GCFScape and grab the original Breen face texture.
If that somehow still doesn’t work for you, it’s probably time to find a new hobby.
Either that or upload it so we can work at it.

  1. Doesn’t work
  2. Doesn’t work too
  3. No!
  4. Here you have a vtf: http://dl.dropbox.com/u/16051712/Breen_face.vtf

Did you move the UV? Or just load it?

Okay out of curiosity where are you putting your unclamped (clamped) texture.
If it’s in addons or something it’s entirely possible it is still loading the original from the sourcce files. Also your VMT could still be pointing at the old VTF and not the new one.

I just loaded it. I am just beginner in 3dsmax.

My model is hexed and uses different directory than original. Also, I had the mistake in VMT that was pointing at original facemap. It’s fixed now, but facemap is still wooden.



...
$cdmaterials "trek_perskin" -all materials are in that folder.
...


God damn it, will you listen to me? I’m telling you what the problem is, I know the exact problem you’re talking about, and the exact solution. Move. The. UV. Map. Up.

AH YES, NOW I KNOW.

But how to do that? Please, tell me that. I’m not a dumb, just a person without know-how.

I doubt it’s a broken UV map. I still think the issue here is a bad referenced texture in some way or another.
If you can show both the QC, SMD and VMT in code tags or pastebin them.

As a last thing try to reclamp the VTF again.

Use VTFEdit to do the clamp ticking, it doesn’t work in Photoshop.

It’s funny how this thread has been so frustrating for such a simple solution.

It’s not broken, it’s just that when you decompile a model, the UV map is pushed down by the height of the texture. It’s not usually a problem, but for some reason, when you recompile a source character, it just stretches the bottom pixels of the texture across the whole mesh (only the face). The simple solution is to open the UV editor, grab the whole face UV, and just drag it up.

The clamp s clamp t thing may or may not work? I’m not sure, but either way I don’t think that’s the correct way to fix this problem.

I’ve decompiled and recompiled countless models already and it has honestly never shown up. The only thing that sometimes happens in my experience is that the UVW gets moved by exactly one unit, but it still essentially in the same space as the original. And only causes issues when you’re rendering the texture for AO maps or bumps.

On the other hand clamping issues, from differing model versions have popped up multiple times and the wooden head syndrome (and multiple small eyes and a few other things) are the pretty much exact syndromes.

It’s entirely possible that some rare UVW bug does happen, I just don’t think it’s the case here.

I’ve seen it show up every single time I decompiled an HL2 character.