Workshop Publisher keeps failing to compress my addon.

I’m having an issue with Garry’s Workshop Publisher not compressing my addon. The Addon Creator works perfectly and creates a valid .GMA file but when it comes time to upload it to the Workshop it just doesn’t want to work. I’m not sure what could be causing this to happen.


gmpublish update -addon "C:\Users\Chris\Desktop\Gmod Holding Area\MCVP.gma" -id "blanketyblank" -changes "Fixed unintended surface properties dependency crash"

Then it will start to execute the command until it gets to the compression stage and will come up with this error:


Compressing.. [241.0 MB] => Failed!

Up until this week I’ve not had any issues with the publisher tool and my addon has been roughly the same size for years now.

I’d assume your addon’s folder is just too big. Anything over 230 MB is pushing the limits from what I’ve experienced. Have you tried moving things to a different addon to see if that’s the issue? (to lower the size)

I think you need to use something like this to allow it to use more of your RAM:

We will be getting rid of direct compression in the upload tool in future updates (it will be handled by Steam)

Well that’s what I’m thinking is the cause, except my addon has been around 240MB for more than a year now, in fact I just rolled out a minor update just last week and it was actually slightly larger then (roughly 241MB) and it was compressed and uploaded just fine (?)

I have also just rolled out an update for my smaller addon (at around 124MB) and it compressed and uploaded just fine.

I’d really prefer not to have to split my old vehicle pack up into smaller chunks though as this is likely to really confuse everyone who is currently subscribed.

Okay so apparently it just worked this time :s:


Compressing.. [240.9 MB] =>  [66.8 MB]