Worldvertextransition(blend texture) problem

It seems that “Worldvertextransition”(which is used for blend textures on displacements) erases the alpha properties of the textures even with $translucent and $alphatest to 1. Anyone know a way around this so that I can get a translucent blend texture?

Why would need that?

Did you also put $translucent and $alphatest on the WorldVertexTransition vmt?

Yes, it still didn’t work : /

Well, the plan was to make a waterfall out of displacements and have a flowing water texture going on it, but on the ends(when the flow starts/stops) fade into nothing(completely invis texture)

Export the displacement and make it a model.

Exporting the displacement and turning it into a model is not the problem, the transition from nothing to flowing water is what I need to figure out how to do

Scrolling texture with a stationary alpha map on a model optimised to the scene.

you can’t have both a translucent texture and an opaque texture in a WorldVertexTransition. read http://developer.valvesoftware.com/wiki/WorldVertexTransition

if you use an $alpha value, it applies to the whole material only

I’m not using a opaque and a translucent texture, the waterfall texture is translucent/alphatest aswell, take a look.
[img_thumb]http://img694.imageshack.us/i/newwater0000.jpg/[/img_thumb]
[img_thumb]http://img407.imageshack.us/i/newwater0001.jpg/[/img_thumb]
[img_thumb]http://img87.imageshack.us/i/newwater0002.jpg/[/img_thumb]

I’ve scrapped $alphatest on the waterfall, invis, and the blend texture. So the only thing they have to rely on is $translucent for the transparency. When I went to go test it in hammer the entire displacement was opaque, so I went to paint alpha, and tried to see if that would do anything, the displacement was still fully opaque. When I tried both the textures individually that make the blend texture appear, they work(being translucent), but not on the blended one.

           So my question is why the fuck is this a supported effect listed for WorldVertexTransition?