Wrong materials on original models

Hello, I haven’t used GMod a lot since the SFM came out, but due to certain videos possible only with gmod’s “style”, I decided to use it again.

Once I load up gmod, start a single player game with a map (koth_viaduct), I spawn some TF2 HWM characters already inside the engine thus in GMod, I get some messed up materials on them, instantly I thought to reinstall GMod and so I did: deleted the local files and re-downloaded the whole “game” again (about 20 minutes at 1.6 MB/s), the issue persists.

I tried on several maps but it seems to be a problem with the models’ materials, weird that happens only on TF2 characters though (either classic and HWM).

Here’s a picture of the Engineer on how he looks, same thing happens with all other 8 characters, I even tried to move away my custom folder from my /tf thinking is something that glitches with GMod, but no luck.

I really hope you can help me, because it’s very annoying and I obviously cannot stop-motion like that.

Please, I haven’t solved this yet and I cannot animate, someone wannabe to help me ? D:

Try running the game with -dxlevel 80

[editline]28th August 2013[/editline]

and make sure your graphics drivers are up to date

Just tried, it didn’t fix it.

I just tried to “add” the folders models and materials from my source filmmaker’s tf_movie, since they appear perfectly in my SFM but with no success: now the HWM models don’t even spawn and the “normal” models have correct materials over their body but with an yellow head.

Are you using the default model? Because SFM models are not supported in GMod.

Yes, I even copied my models and materials folders from TF2 to GMod, now the overall body texture is OK, but the face is still blue.

Also now I can only spawn the “classic” models, if I spawn an HWM it doesn’t appear at all in-game and this appears in the console:



MDLCache: player/hwm/heavy.mdl needs to be recompiled
Ignoring material flag '$ignorez' on material 'models/colors/yellow.vtf'.
Ignoring material flag '$ignorez' on material 'models/colors/yellow.vtf'.
No such variable "$texture2transform" for material "models/player/hvyweapon/invuln_lightning_anim"
Error: Material "models/player/hvyweapon/invuln_lightning_anim" : proxy "TextureTransform" unable to initialize!
Ignoring material flag '$ignorez' on material '1'.
Ignoring material flag '$ignorez' on material '1'.
Ignoring material flag '$ignorez' on material '1'.
Ignoring material flag '$ignorez' on material '1'.
Error Index File for 'player/hwm/heavy.mdl' checksum 1677076149 should be 2124556973
Attemped to precache unknown particle system "sandwich_fx"!
Error reading material data "materials/effects/invun_red_hdr.vtf"
Error reading material data "materials/effects/invun_red.vtf"


Update:

I deleted both folders once again and copied them from my TF2 directory.

Now the classic models are perfect, the HWM models SPAWN, but they do have blue/yellow heads (depending on bodygroup skin).

Guys, any news on this issue ? I haven’t solved it yet…

Haven’t fixed the issue yet so… had to bump the thread for the sake of a solution :l

Aww please, help me D:

Anybody wannabe to help me out ? .-.

UP !!!

Anyone that could help me solve this annoying issue with TF2 models’ textures ???

First off, it’s called bump, not up. Secondly, where did you get these models again? Or are you using the default one from your TF2 menu?

I’m using the default ones, I’ve even tried replacing them from my /tf directory, but the issue seems in the materials, getting overwritten by those glitched ones whenever I launch gmod.

I’ve tried several times several ways to fix it:

  • deleting materials & models from gmod
  • replacing them with SFM ones (didn’t work, so I tried with TF2)
  • replaced them with TF2 ones

still nothing !!!

The weird thing is that the “normal” ones look good, the issue comes with HWM ones, which are the ones I use more and I need more (since they are… well, overall better).

Also, sorry for the “bump”, I’m too used with the other term :wink:

Try disabling all of your addons to make sure none of those are causing issues. If that doesn’t work, follow these steps.

  1. Delete any garrysmod folders in /steamapps/common or (username).
  2. Turn off Steam Cloud sync for Garry’s Mod so no overwriting materials redownload.
  3. Reinstall.

Hi, sorry for the late reply.

I’ve already done these things since the beginning of the issue.

I’ve disabled all of my in-game addons, even uninstalled gmod and reinstalled it in the same location and then tried also to reinstall it on a separate steam library on one of my internal hard-drives.

Nothing of these fixed the issue, neither denying it to connect to the Steam Cloud service, it feels like a much deeper issue there…

I’ve tried everything, everything I could come up with… but I won’t give up, I’ll never gonna give up, I NEED GMod, I WANT to make new videos with GMod…

have you got any other advice, code_gs ?

If this doesn’t happen in TF2 and if you’re sure you’re using the correct models, I have nothing else.

On TF2 everything’s fine, I don’t even have such skins inside my “custom” folder (only a few replacements, but for weapons, nothing for the characters).

I’d appreciate if someone could hand me the original materials and models folders of TF2 characters, testing it with “foreign” coming ones might be my last chance.

You can extract the materials and models from the gcf files (or whatever they’re called)

Extract the TF2 .vpk’s with GCFScape and get the models.