Wtf, blood splatter won't work.

You know when you shoot a zombie, and all these green splatters go flying everywhere? I don’t have that anymore. You know when you shoot a combine and blood splatters are flying? I don’t have that either. I did a system restore, hoping that’d fix it…it didn’t do crap. In fact, the splatter used to be just bright red, and now they’re completely gone. I’m getting depressed, since I have no idea what in the freaking world is happening. It was working fine until recently. Please help me!

[editline]02:57AM[/editline]

Forgot to mention, when I kill things that have yellow/green blood, it says “attempting to load particle blood_splat_yellow_01” or something like that.

Hmm, do you downloaded custom blood?

No. :frowning: I got goremod, but when I got rid of that, it had no effect on the blood. It just randomly started happening. I deleted local content of GMod Hoping that it would reload the files. It did bring back the blood for combine, but once again, it’s crappy looking and bright red. Could it be a glitch from a steam update?

Does it look like this?

http://filesmelt.com/Imagehosting/pics/395992ef41c1121c3e05b4881ae307ea.jpg

Yeah my gmod has been having the same kinds of problems, with some others here:

http://filesmelt.com/Imagehosting/pics/7e2719ff5710a9a2511043bd456d9fcc.jpg

The wireframe blood splatter.

http://filesmelt.com/Imagehosting/pics/6f04d0753a127ef18d3fff6404130cba.jpg

You can see here that the menu will go transparent.

http://filesmelt.com/Imagehosting/pics/f052a2311629b0ba2856791a9bb2412a.jpg

Here the water looks almost like a sheet of tinted glass.

http://filesmelt.com/Imagehosting/pics/311800db4d32957021a5cb27a5aff069.jpg

An interesting shot underwater. You can see the bullet impacts on the ground, but you can’t actually see the ground.

http://filesmelt.com/Imagehosting/pics/536083042c660f9d5c8f4bb6b823f0f8.jpg

And finally, this. FYI, that M4 is from the css realistic weapon pack, but note that there is no muzzle blur when i shoot.

I’ve tried putting -dxlevel 9 in the launch options, but that doesn’t seem to be any good. The only thing I can figure would’ve caused this would be me setting gmod to run in a window last week. I began seeing these issues since then, and even after changing it back to fullscreen, it still doesn’t work.

No. You must put -dxlevel


90

in, not -dxlevel 9. In other words, you tried to run the game in Direct X 0.9!

Aaaah, you’re kidding me. Well, back to work then. Thanks anyway for the tip.

It actually looks like a PC fault to me. Are you graphics drivers up to date?

No, it’s not. I put -dxlevel 90 in the launch options, and it’s fine.