Wtf?

I’ve got yet another extremely annoying problem with hammer.
It seems like maybe something easily fixable? Well I’ve got my map to a testing point. I compile
and there’s no problem at all there, but when I load it up in Gmod or CS:S. It loads, loads, loads until…
“hl2 exe. has stopped working”

Solution?
And here’s the compile log.

** Executing…
** Command: “d:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk\bin\ep1\bin\vbsp.exe”
** Parameters: -game “d:\steam\steamapps\wgk@tampabay.rr.com\counter-strike source\cstrike” “D:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel”

Valve Software - vbsp.exe (Dec 11 2006)
4 threads
materialPath: d:\steam\steamapps\wgk@tampabay.rr.com\counter-strike source\cstrike\materials
Loading D:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel.vmf
fixing up env_cubemap materials on brush sides…
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (0)
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (0)
Processing areas…done (0)
Building Faces…done (0)
Chop Details…done (0)
Find Visible Detail Sides…done (0)
Merging details…done (0)
FixTjuncs…
PruneNodes…
WriteBSP…
done (0)
writing D:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel.prt…done (0)
Creating default cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_01*.vmt
Run buildcubemaps in the engine to get the correct cube maps.

No such variable “$hdrbasetexture” for material “skybox/sky_day01_01rt”
Can’t load skybox file skybox/sky_day01_01 to build the default cubemap!
Finding displacement neighbors…
Finding lightmap sample positions…
Displacement Alpha : 0…1…2…3…4…5…6…7…8…9…10
Building Physics collision data…
done (0) (93627 bytes)
Error loading studio model “”!
Error! To use model “models/props_c17/door01_left.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/props_c17/door01_left.mdl”!
Error loading studio model “models/splayn/rp/lr/couch.mdl”!
Error! To use model “models/props_lab/scrapyarddumpster.mdl”
with prop_static, it must be compiled with $staticprop!
Error loading studio model “models/props_lab/scrapyarddumpster.mdl”!
Placing detail props : 0…1…2…3…4…5…6…7…8…9…10
Compacting texture/material tables…
Reduced 247 texinfos to 175
Reduced 42 texdatas to 37 (980 bytes to 781)
Writing D:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel.bsp
4 seconds elapsed

** Executing…
** Command: “d:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk\bin\ep1\bin\vvis.exe”
** Parameters: -game “d:\steam\steamapps\wgk@tampabay.rr.com\counter-strike source\cstrike” “D:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel”

Valve Software - vvis.exe (Nov 8 2007)
4 threads
reading d:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel.bsp
reading d:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel.prt
455 portalclusters
1311 numportals
BasePortalVis: 0…1…2…3…4…5…6…7…8…9…10 (0)
PortalFlow: 0…1…2…3…4…5…6…7…8…9…10 (9)
Optimized: 307 visible clusters (0.00%)
Total clusters visible: 80226
Average clusters visible: 176
Building PAS…
Average clusters audible: 431
visdatasize:52023 compressed from 58240
writing d:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel.bsp
9 seconds elapsed

** Executing…
** Command: “d:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk\bin\ep1\bin\vrad.exe”
** Parameters: -game “d:\steam\steamapps\wgk@tampabay.rr.com\counter-strike source\cstrike” “D:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel”

Valve Software - vrad.exe SSE (Nov 8 2007)
----- Radiosity Simulator ----
4 threads
[Reading texlights from ‘lights.rad’]
[1 texlights parsed from ‘lights.rad’]

Loading d:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel.bsp
1400 faces
15 degenerate faces
118668 square feet [17088284.00 square inches]
0 displacements
0 square feet [0.00 square inches]
1385 patches before subdivision
10769 patches after subdivision
2 direct lights
BuildFacelights: 0…1…2…3…4…5…6…7…8…9…10 (3)
BuildVisLeafs: 0…1…2…3…4…5…6…7…8…9…10 (1)
transfers 772102, max 487
transfer lists: 5.9 megs
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #1 added RGB(2415, 2117, 1872)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (0)
Bounce #2 added RGB(285, 228, 137)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #3 added RGB(76, 59, 30)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (0)
Bounce #4 added RGB(23, 16, 6)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (0)
Bounce #5 added RGB(10, 6, 2)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #6 added RGB(5, 2, 1)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (0)
Bounce #7 added RGB(2, 1, 0)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #8 added RGB(1, 0, 0)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (0)
Bounce #9 added RGB(1, 0, 0)
Build Patch/Sample Hash Table(s)…Done<0.0055 sec>
FinalLightFace: 0…1…2…3…4…5…6…7…8…9…10 (0)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ComputePerLeafAmbientLighting: 0…1…2…3…4…5…6…7…8…9…10
Ready to Finish

Object names Objects/Maxobjs Memory / Maxmem Fullness


models 7/1024 336/49152 ( 0.7%)
brushes 233/8192 2796/98304 ( 2.8%)
brushsides 1579/65536 12632/524288 ( 2.4%)
planes 928/65536 18560/1310720 ( 1.4%)
vertexes 2918/65536 35016/786432 ( 4.5%)
nodes 947/65536 30304/2097152 ( 1.4%)
texinfos 175/12288 12600/884736 ( 1.4%)
texdata 37/2048 1184/65536 ( 1.8%)
dispinfos 0/0 0/0 ( 0.0%)
disp_verts 0/0 0/0 ( 0.0%)
disp_tris 0/0 0/0 ( 0.0%)
disp_lmsamples 0/0 0/0 ( 0.0%)
faces 1400/65536 78400/3670016 ( 2.1%)
hdr faces 0/65536 0/3670016 ( 0.0%)
origfaces 812/65536 45472/3670016 ( 1.2%)
leaves 955/65536 30560/2097152 ( 1.5%)
leaffaces 1588/65536 3176/131072 ( 2.4%)
leafbrushes 565/65536 1130/131072 ( 0.9%)
areas 2/256 16/2048 ( 0.8%)
surfedges 10158/512000 40632/2048000 ( 2.0%)
edges 5932/256000 23728/1024000 ( 2.3%)
LDR worldlights 2/8192 176/720896 ( 0.0%)
HDR worldlights 0/8192 0/720896 ( 0.0%)
waterstrips 118/32768 1180/327680 ( 0.4%)
waterverts 0/65536 0/786432 ( 0.0%)
waterindices 2118/65536 4236/131072 ( 3.2%)
cubemapsamples 0/1024 0/16384 ( 0.0%)
overlays 0/512 0/180224 ( 0.0%)
LDR lightdata [variable] 385328/0 ( 0.0%)
HDR lightdata [variable] 0/0 ( 0.0%)
visdata [variable] 52023/16777216 ( 0.3%)
entdata [variable] 7819/393216 ( 2.0%)
LDR leaf ambient 955/65536 22920/1572864 ( 1.5%)
HDR leaf ambient 0/65536 0/1572864 ( 0.0%)
occluders 0/0 0/0 ( 0.0%)
occluder polygons 0/0 0/0 ( 0.0%)
occluder vert ind 0/0 0/0 ( 0.0%)
detail props [variable] 1/12 ( 8.3%)
static props [variable] 1/3924 ( 0.0%)
pakfile [variable] 20971/0 ( 0.0%)

Level flags = 0

Win32 Specific Data:
physics [variable] 93627/4194304 ( 2.2%)
==== Total Win32 BSP file data space used: 924824 bytes ====

Total triangle count: 4029
Writing d:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel.bsp
9 seconds elapsed

** Executing…
** Command: Copy File
** Parameters: “D:\steam\steamapps\wgk@tampabay.rr.com\sourcesdk_content\cstrike\mapsrc\Hotel.bsp” “d:\steam\steamapps\wgk@tampabay.rr.com\counter-strike source\cstrike\maps\Hotel.bsp”

** Executing…
** Command: “d:\steam\steamapps\wgk@tampabay.rr.com\counter-strike source\hl2.exe”
** Parameters: -game “d:\steam\steamapps\wgk@tampabay.rr.com\counter-strike source\cstrike” +map “Hotel”

Run the compile log though here

I already checked the compile checker.
Nothing that would explain why it’d make the exe. fail.
What typically causes HL2 to stop working?

Try loading up HL2 by itself and load a level. Or try to restart your computer

My games work fine. They load up other maps. ( Keep in mind this is a CS:S, Gmod map )
I tried HL2 for the heck of it and they both work just fine.
Restarting didn’t do anything… This is annoying… D:
Could custom textures be the problem? I mean… I’m loading it up in CS:S mostly ( where the custom textures are located, the “cstrike/materials” directory )

Try using the cordon tool to test sections of the map at a time.

Custom textures are unlikely to be the problem. You have some degenerate faces which suggests potential for bizzare geometry errors. Some things to try include visgrouping out all your entities and then adding a player start and compiling. If that works, then it’s a problem with your entities. If it doesn’t then I suggest trying cordoning off bits of the map and recompiling till you find the error.

Probably sounds incredibly stupid, but how would I visgroup out entities?
I’m kinda still new to mapping. :confused:

By default, the Visgroup toolbox is on the right side of the Hammer window. Click on the Auto tab and uncheck any entity options desired.

I know that the game crashed once exactly as you explain it. I later figured out it was a bad entity output that caused it to crash.

Why does it say “counte r-strike”?

Thanks to you all =D.
I did the entity thing. I figured out it was something wrong with either the double doors
or the ep1 dumpster. Either way I can at least test what I needed to.

Forum bug. It splits up long strings.