XBOX 360 Kinect Doesn't Work For Gmod.

My XBOX 360 Kinect Doesn’t Work For Garry’s mod.
I’ve noticed something wrong is that the first circley light thing from the left doesn’t have a little red light when I use it on my computer but when I use it on my XBOX 360 it does.

Another thing is that I installed Kinect SDK 1.0 BETA 2 but only the skeletal detecting thing would work and switch on the infrared sensor.
I Really wana play with the ragdolls.
Any help would be appreciated.
:downs:
EDIT:
If I posted this on the wrong sub-forum please forgive me.

Are you running the SVN version of garrys mod?

kinect support hasn’t officially been released for gmod yet…

What is the SVN link?

http://svn.facepunchstudios.com/svn/gm/

I believe its that.

Yes I’m using the svn version.

Same problem here too. 6 hours I’ve spent troubleshooting today. I’m now 100% certain I have the most recent SVN version, and I am able to individually run it in Steam. And no Kinect option with a working Kinect.

I’ve spent 2 days.
2 days.
:suicide:

Are you also using Kinect for Windows Runtime v1.6 like Garry states in the wiki? Not sure if that version is totally needed but I’m just trying to follow everything.

something tells me that it’s NOT in the current SVN, and that someone who never even tried it out just lied about it.

Yes im using v1.6

Bump :’(


(User was banned for this post ("Dumb bump" - Craptasket))

It is in the SVN, I was using it earlier - though I could not get the video mirror in the bottom left to work.

Are you sure that your Kinetic is being recognized by the computer? (Have you tried using it with any other software?)

Edit:

I assume you know this but I’ll throw it in here, the option on the ragdoll is ‘Control with Motion sensor’ .

Also, I have the SDK and Developer toolkit installed as well.

Yep, my computer recognizes Kinect and I was using the Developer Toolkit earlier to demo the depth views, skeleton recognition, etc. Works fine.

Edit: Alright, I was confusing the SDK and sneaky link for the runtime. I just installed the runtime…is it meant to install in less than a second from when you click “I agree”? Anyway,
Setup Complete". I have the runtime v1.6, the SDK v1.6…still doesn’t work. I’m out of ideas.

while in the svn, it still says that the **version number is 152, same as the current gmod. **Is this supposed to be different? To be even more sure: is the folder I place in the Sourcemods folder supposed to be the 2nd garrysmod folder, which you’d see inside of another folder called “garrysmod”? (So no hl2.exe, etc files should be in this garrysmod folder in souremods?)

Furthermore…was http://svn.facepunchstudios.com/svn/gm/ the right link to download from, or is that just the current version? Someone on YouTube linked me there saying that was the not-yet-released version with the Kinect code.

I got the same problem but I didn’t even know that I have to put the SVN in the Sourcemods folder.

Once it’s properly in that folder, you should see a second “Garrys Mod” in Steam, but this one won’t have the background graphic on its steam page.

Well… I tried it but I don’t see a second Garry’s Mod in the Steam Library

Make sure the “garrysmod” folder you put in “sourcemods” is actually the second gmod folder…

Garrysmod–>Garrysmod–>materials, maps, etc etc,

make sure to make it that second folder, not the first one

Dunno if that’s the correct way, but that’s what I did and now I can run the secondary gmod from Steam.

It is. Am I putting it in the right sourcemods folder?

Sorry for the Czech language

No man, the folder on the right in your image, take the “garrysmod” folder from THAT garrysmod folder, and put that in “sourcemods”

Edit: SUCCESS

I uninstalled all my Kinect downloads and did it in the right order this time: Runtime, THEN SDK, then…nothing, I didn’t install the Dev Tools. This time, opening gmod, I see the “kinect sdk found” message in the console. Works like a charm now. I can control with Kinect. It’s GLORIOUS.

Oh… cool I see it, thanks… I’m gonna test if I can see the Kinect button