XGUI group permissions

So I have looked everywhere, but i have not been able to find a real solution to my problem. I have ulx and ulib installed, but recently I have been locked out of my group permissions page. I am a superadmin (as the owner) and I have not tried to create a class higher than superadmin (because that would be redundant). I go to xgui>groups tab>superadmin>manage permissions, but the menu there is gone, and I haven’t done anything (to my knowledge) that would interfere with my ability to use that page. I’m just looking for a way to get back into that tab, so I dont have to search everywhere and manually enter new commands for my groups and such. Any help would be very appreciated! :slight_smile:

TL;DR locked out of group permissions, want to know how to get back in.

“xgui_managegroups” is the permission you’re looking for- enter this in RCON or your client console, and you should get it back.


ulx groupallow superadmin xgui_managegroups

I have tried that before, but all that ended up doing was trying to give me access to the groups tab, not actually manage permissions in the groups themselves.

Ah, in that case you’ll need to do “ulx groupallow superadmin groupallow” and “ulx groupallow superadmin groupdeny”, and you should be able to fix the rest from there.

EDIT: Oops- wait, you say you can see the groups tab, but nothing shows up after you click “Manage Permissions”? That’s probably a bug. Could you try making sure you’re up-to-date with the latest versions of ULX and ULib from here? https://github.com/Nayruden/Ulysses

In the end, I had to completely reinstall ulx and ulib, because I tried removing and replacing the data, and it was still messed up. Reinstalling worked, but it did mean that I had to completely redo all of my groups and permissions, as well as get all of the extra commands I added back.

Hmm, that’s rather odd. Sorry about that! If you would like to (and still have backups), PM me your groups.txt and users.txt files, and/or any other ULX/ULib data files that may be relevant, and I can see if I can replicate the issue.