You are in insecure mode. You must restart before you can connect to secure servers

I’ve tried verfying game cache only made my game not work and I had to delete the garrysmod/bin folder again
Tried running both steam and gmod as admin
tried running -autoconfig
-insecure is not in my launch settings there’s only -secure and -console
I’ve unsubbed from all of my mods
restarted my game, steam and PC and it still doesn’t work
Please help :cry:

delete the /addons folder, if that doesnt work, reinstall the game.

Reinstalling the game only makes me get the gmhtml error and then I delete the bin folder again and I still get the insecure error, and I have deleted the addons folder before didn’t work.

Check your firewall, maybe its blocking gmod? Also, are you SURE you didnt crack gmod? If you did, then thats the problem, cracked gmod can only connect to insecure servers.

Nah didn’t crack I have it on steam lol Nope don’t use a firewall

I’m guessing this is the source of your issues.

What do you mean by that?

Don’t delete the bin folder…

If I don’t delete it I get this :
Engine Error - Couldn’t Load Library ‘gmhtml’ (looking for interface IGMHTML001)

Fixed the error by just copy/pasting every folder in the main gmod folder in garrysmod

Restarting isn’t going to do anything. You’re going to have to get some new hardware for your router and you will probably have to do some reinstallations.