"You've hit the Lights limit!"

Every so often I host Garrysmod LAN listen servers for me and my friends around our college campus, and it works fine, except for one bizarre issue. Whenever someone creates a light (note, not a lamp, but a light emitter) we get an error saying “You’ve hit the lights limit.” I looked through the Sandbox settings before I create the server, and there is no setting to change the maximum lights. I looked through the sbox_max_??? console commands, and likewise, there’s nothing related to maximum lights. It’s not a huge issue, but its a bit weird and annoying, since we want to make space ships that aren’t totally dark on the inside while we fly around in them.

Anyone know how to fix this?

I think you want this.


sbox_maxlights <number>

“Unknown command: sbox_maxlights”

Just type in “sbox_” and check autocorrect for each additional key entered.

Edit: My idea being that you might’ve misspelled it or something.

I typed sbox_ and went though the entire list until it repeated. There is no “maxlights” option or anything similar, only maxlamps.

It worked for me.

Are you running it through RCON?